拡張機能のアップグレードに失敗しました:ダウンロードに失敗しました – ZIPファイルが利用できないか、形式が正しくありません

I’m using CiviCRM 5.0.0 and WordPress 4.9.5, I have CiviRules
1.19 and I have notice that Version 1.21 is available. So I click
to update but it has error like picture: Extension Upgrade
Failed Download failed – ZIP file is unavailable or
malformed

enter image description here

これを修正する方法を教えてください。

ベストアンサー

手動アップグレードを行うことができます:

  1. rel=”nofollow
    noreferrer”> https://civicrm.org/extensions/civirules

    からzipファイルをダウンロードします。
  2. サーバーの拡張フォルダからcivirulesディレクトリを削除する
  3. ダウンロードしたzipファイルを解凍する
  4. サーバー上の拡張フォルダにorg.civicoop.civirulesフォルダをアップロードします
  5. civicrmの拡張ページに移動し、データベースのアップグレードが完了しているかどうかを確認します。

ps。手順1の前にバックアップを作成するのは良い習慣です。

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です