4.7.29にアップグレードするとcronで内部サーバーエラーが発生する

私は昨日テストサイトを4.7.29(固定型)にアップグレードしました。それ以来、cronは500サーバエラーで失敗しています。

私たちはWordpress 4.9.2で動いています。 cronは今まで何年も成功しています。

cron.phpへのURLを使用して30分ごとにcronジョブを実行しています。
私はcron.phpパーミッションをチェックしました。それらは変更されておらず、ユーザーとパスワードがまだ有効であり、十分な許可を持っていることを確認しています。コマンドラインから直接コマンドを実行すると、ブラウザでも同じように500の内部サーバーエラーが発生します。私たちがしたのは、CiviCRMのバージョンをアップグレードすることだけでした。
助けて?

ベストアンサー

そこで私はこの問題を解決しました。ここに私が見つけたものがあります。ある時点で bin
の権限が 755 から 775
に変更されているようです(私のバックアップを見て、 755であったが、4.7.29では775に設定されていた。)

私はこの質問と回答を使用しました:
cronジョブのURLから404エラーが表示される
(同じエラーではありませんが、必死に検索していました!)

同じ変更を加えました(更新されたビンのパーミッションが755
)。だから今は良いですが、アップグレードするたびに権限を更新する必要がありますか?

返信を残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です