バージョン4.7.31にアップグレードするとDAO.PHPが壊れているようです

バージョン4.7.31がインストールされ、今では毎時のcronジョブが次のようにエラーになります。

“Parse error:構文エラー。予期しない ‘[‘ in
/…/administrator/components/com_civicrm/civicrm/CRM/Core/DAO.php
651行目。

すべての手がかりは?

ベストアンサー

サポートされているバージョンのPHPを使用していない可能性があります。私はあなたのバージョンをチェックします。私の推測では、5.5がCivi
4.7.31のサポートされている最小バージョンであるため、PHP 5.4を使用していると思います。

すぐにPHPをアップグレードする立場にない場合は、バックアップからサイトを復元しますが、私の助言はPHPをアップグレードすることです。
PHP 5.4は安全ではないことが知られており、ほぼ3年間のセキュリティアップデートを受けていません。

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です