CiviCRM 4.7で動作する拡張機能も5.xと互換性がありますか?

私の拡張機能のほとんどは4.7と互換性があるとマークされていますが、5.0,5.1などで動作することは明示的には言いません。CiviCRMを安全にアップグレードして拡張機能を引き続き使用できますか?

ベストアンサー

5.0には変更の破棄が含まれていないため、4.7の拡張と同等の互換性があるとみなされます。ソフトウェアをアップグレードする際には常に破損の危険がほとんどありませんが、4.7から5.0まではメジャーアップグレードとはみなされません

From https://lab.civicrm.org/dev/release/issues/1#note_2843

      

  • 4.xシリーズでは、タグは今日と同じ意味です。 (バージョンとの完全一致。4.6を宣言する拡張子は表示されません
      4.7でダウンロードしてください。)
  •   

  • 5.xシリーズでは、タグは前方互換性を意味します。 (5.2を宣言する拡張子は5.2,5.3などに表示されますが
      5.0ではなく)。
  •   

  • それらを橋渡しするために、4.7は5.0と前方互換性があります。
    (4.7、5.0、5.1、などに4.7が宣言された拡張子が表示されます)
  •   

  • 今日のように、消費者はそのバージョンと互換性のある最新の拡張機能を見ています。
  •   

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です