永続的な “データベースはすでにCiviCRMにアップグレードされています”問題

私はCiviCRMをWordPress 4.9.4で4.7.27から4.7.31にアップデートしています。
CiviCRM以外は、すべて最新のものです。

私は徹底的に問題をGoogleで調べて、3回更新を試みました。しかし、「あなたのデータベースはすでにCiviCRM
4.7.27にアップグレードされています」という問題は解決されません。私は WordPress用のCiviCRMをアップグレードする ”
a>はWordPressとCiviCRMの現在のバージョン用です。

特に、他の人々が抱えていた問題に対処するために、

  • FTP経由でmy/wp-content/plugins/civicrmフォルダを完全に削除しました(名前を変更しただけではありません)。
  • CiviCRM 4.7.31の新しいコピーをダウンロードし、ローカルに解凍し、civicrmフォルダを/
    wp-content/pluginsにアップロードしました。私はcivicrm.phpのリモートコピーがヘッダーのバージョン4.7.31を参照していることを確認しました。
  • /wp-content/uploads/civicrm/templates_cのファイルを削除しました。
  • ブラウザのキャッシュを消去しました(Chromeを使用しています)。
  • サイトファイルの不正なcivicrmプラグインディレクトリを検索しました。何もありません。

このすべては、wikiのアップグレード記事の他のすべての関連手順に加えて、
(ローカライゼーションファイルは使用していません)。

何も動作しません。アップグレードスクリプトを実行すると、「あなたのデータベースはすでにCiviCRM
4.7.27にアップグレードされています」という気がします。

私は何が欠けていますか?問題の原因は何ですか?

ありがとう!

ベストアンサー

あなたの助けのために@PradeepNayakに大きな感謝!問題はcivicrm.settings.phpのパスではありませんでしたが、その提案は私たちの設定を見てくれました。私たちは開発サーバーとステージングサーバーの間にいくつかの混乱があったことが分かりました。実際、正しいインスタンスを更新していませんでした。本質的に、データベースからのバージョン番号は正しかったが、ファイルバージョンの間違った場所を探していた。

返信を残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です