このErrorWarningの意味は、WPの新規インストールの要件をチェックするときの意味ですか?

CiviCRMの要件を満たす表示する新しいホスト(SiteGround)にciviCRMの新しいステージングインストールを行うことを検討しています。
CiviCRM 4.7.31 ワードプレス4.9.4

しかし、私はWordpressのCiviCRMのチェック/インストール時に以下のエラーを受け取ります。

ErrorWarning: mysqli_real_escape_string() expects parameter 1 to be mysqli, boolean given in /home/peritawe/public_html/tbe/wp-content/plugins/civicrm/civicrm/install/index.php on line 1299

1299行目以降は、

  $query = sprintf("CREATE DATABASE %s", mysqli_real_escape_string($conn, $database));
  if (@mysqli_query($conn, $query)) {
    $okay = ts("Able to create a new database.");
  }

私はCiviのインストーラが「間違っている」と言うので、MySQLデータベースの詳細をチェックするための何かをすることはできないと推測していますが、ユーザ名とパスワードを3回チェックして、MySQLユーザはデータベースにアクセスします。

何が起きてる?
ここに記載されているCiviCRMの4.7.21の問題に似ていますか?
(私はCivi
4.7.20でインストールをチェックしましたが、同じエラーがありました。

ベストアンサー
申し訳ありませんが、適切な答えはありません

返信を残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です