WordPress Ajax&写真は5.0へのアップグレード後に読み込まれません

4.7.29から5.0.0に更新しました SQLの更新は順調でしたが、私はJS/Picturesに問題はありませんでした。
たとえば、「新しい連絡先を作成する」が読み込まれていないなど、これは実際にはブロックされています
以下のスクリーンショットを参照してください。 アドバイスをお願いしますか? ありがとう

enter image description here enter image description here enter image description here enter image description here enter image description here

「新規ユーザーページの作成」でエラーが発生しました

CiviCRM_API3_Exception: “DBエラー:そのようなフィールドはありません”

0
/var/www/html/civicrm/wp-content/plugins/civicrm/civicrm/CRM/Core/BAO/UFGroup.php(3341):civicrm_api3(
“uf_group”、 “get”、(Array:3))

1/var/www/html/civicrm/wp-content/plugins/civicrm/civicrm/CRM/Contact
/

2
/var/www/html/civicrm/wp-content/plugins/civicrm/civicrm/CRM/Contact/Form/Location.php(107):CRM_Contact_Form_Edit_Address
:: buildQuickForm(オブジェクト(CRM_Contact_Form_Contact))

ベストアンサー

I can see the problem (I saw this myself recently), but I don’t
have a 100% answer. However, the solution is usually to
rebuild your multilingual schema.

この問題の特徴は次のとおりです。

  • CiviCRMサイトで多言語モードが有効になります。
  • ブラウザコンソールのファイルに、 “undefined”という単語があるパスにファイルが見つかりませんでした。
  • また、「DBエラー:そのようなフィールドはありません」というエラーが発生します(これは、拡張子がないか、CiviCRMファイルをアップグレードした後にデータベースをアップグレードできないことによっても発生します)。

これらの手順に基づいて、多言語スキーマを再構築する方法は次のとおりです。

CiviCRM内から(CiviCRM 5.1+のみ):

  • [サポートメニュー>開発者> APIエクスプローラ]に移動します。
  • エンティティ」をシステムに、操作多言語スキーマの再構築
  • 実行ボタンを押します。

コマンドラインから(Civi 5.0.1以前):

Drupal 7

drush php-eval 'civicrm_initialize(); CRM_Core_I18n_Schema
:: rebuildMultilingualSchema(["en_US"、 "fr_CA"]、NULL); '

Drupal 8

drush php-eval
'Drupal::service('civicrm')->initialize();
CRM_Core_I18n_Schema::rebuildMultilingualSchema(["en_US","fr_CA"],
NULL);'

WordPress

wp eval 'civicrm_initialize(); CRM_Core_I18n_Schema ::
rebuildMultilingualSchema(["en_US"、 "fr_CA"]、NULL); '

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です